DG60 - Troubleshooting - Can't pair

Follow

Normally, when we pair the DG60 with a new Bluetooth device it takes between 5~10 seconds depending on the environment.

Not being able to pair or difficulties in pairing may be due to the following:

  1. BOTH devices have not been set into PAIRING MODE correctly. 
  2. Your Bluetooth device or the DG60 unintentionally paired/connected to another Bluetooth device instead.
  3. A large amount of wireless interference in the environment interference, for example if the Leaf is positioned very close to a WiFi router.

To ensure a smooth pairing between your DG60 and your Bluetooth device, please turn OFF other nearby Bluetooth devices and find a location away from sources of wireless interference. Then please try the following:

  1. Reset/Clear the pairing history of the DG60 - https://support.avantree.com/hc/en-us/articles/360031105071
  2. Reset/Clear the pairing history of your Bluetooth device - refer to its user manual (or search for instructions online) 
  3. Ensure the DG60 is in PAIRING MODE - Hold the MFB for 2 seconds,  the LED will flash BLUE and WHITE alternately.
  4. Enter your Bluetooth device into PAIRING MODE. In most cases this is indicated by the LED flashing quickly or two colors LED flash alternately. 
  5. Keep both devices close, and wait for them to connect. 

If you do not know how to reset your Bluetooth device or how to enter it into pairing mode, please let us know at support@avantree.com and we will help to find this information for you.

If this FAQ cannot resolve your issue, please contact us at support@avantree.com, tell us the issue, and we will do our best to help. Thanks!

Have more questions? Submit a request

Comments